AtomicDex refunds seem to fail?

So far using Atomic Dex has been a real pleasure to use, great user experience. Using it both on Android and Linux. Most of the Swaps went trough, some were fast, some were slow, but in the end they all succeeded.

Until recently when two did stop halfway through. The first reporting “Maker payment confirm failed” and the second “Taker payment validate failed”. After which a refund proces started. My Lynx payments had been send and it was confirmed on the blockchain. So far the receiving addresses have not yet redeemed the received LYNX. (And I guess these addresses cannot because the LYNX payment is locked?)

The value of the LYNX send is not that much, that is not my issue. But it seems it is possible to quit an Atomic Swap just before Maker / Taker payments get validated, while the payments have been send. And though the refunding proces starts it somehow does not return the payments. Not even after almost a day of leaving my laptop running.

The LYNX I send I do consider lost, as the refunds proces did start, but none succeeded so far. Could this be a bug. Or worse, a way to get a payment and then pull out before validation? Meaning nothing has to be send in return.

For Cryptos like LYNX I consider it not a disaster that I lost them like this. But I can imagine cases where I absolutely would want a refund to function as it should.

EDIT: Seems like the Linux Atomix Dex has some issues. The Linux Appimage 0.4.3 does not run but the beta 0.4.3 zip did , 0.4.2 crashes. (It might be a recent Linux Unbuntu / Lubuntu update causing the Dex to not function like it should anymore.)

Hi oldambster,

Please drop in to #support channel and we can review the logs and addresses. Worst case scenario, funds will be recoverable through a manual refund with the API - DEX API | Komodo Documentation

If you exit the app and then restart it once swap times out, a “recover funds” notification and button should appear.


Which version of Ubuntu are you running? 16.04 is no longer supported in releases (but you could still build it manually) as it has reached EOL - Ubuntu 16.04 Reaches End of Life. Still Using It? Here Are Your Options! - It's FOSS News

Using 20.04 completely updated.

Hi smk762,

Tried the API recovery part, but unfortunately I get errors constantly. Mostly concerning my user password.

Weird thing being that the API does not seem to like passwords containing &,$,@,# and so on. While the Atomic Dex enforces the use of it.

Removed all data, recovered my Atomic Dex using the seed and used a different $,@,&,# creating a password. Same trouble using Curl.

One thing I noticed on a mobile Android AtomicDex I run constantly, it gobbled up 17+ GB overnight. Flushed it in the settings. Will keep an eye on it, no idea how or why it got that high.

Back to the lost LYNX Coins, I consider them gone, lost and locked. First time this happened, hopefully the last time. :slight_smile:

Kind regards